Inventory & Sales Module
KEY FEATURES

1. Maintain multi locations
2. Maintain user wise location access permission
3. Maintain FIFO, Serial and Batch wise inventory
4. Maintain Case/Piece wise inventory
5. Attached multiple graphic types (BMP, GIF, JPG, PNG, and TIFF) multiple images to the product.
6. Supersede the Vendor Product Code
7. Bin Location wise inventory maintenance and Product collecting order from the bin location.
8. Facilitate to upload and download bulk of serial/batch numbers
9. Supports multicurrency
10. Maintain Customer, Currency and Product wise Sales Price (Multiple Price levels)
11. Maintain Sales Rep, Customer and Product wise Discount Schemas
12. Avoid backdated data entering
13. Avoid usage of insufficient stock
14. Parameterized Tax Calculations (Forward/Reverse) AND Maintain user defined taxes
15. Maintain Credit Controls AND Bypass the credit controls with higher authority.
16. Facilitate to generate invoice with or without dispatch.
17. Facilitate to maintain promotions (free issues) at the invoicing time.
18. Facilitate to settle the invoice with multiple payment modes at the invoicing time
19. Define monthly Sales Target
20. Maintain intercompany location transfers.
21. Physical Stock Reconciliation
22. Depreciation Process
23. Product Inquiry with all the transaction details

REPORTS
24. Bin Card
25. Location Stock Detail
26. Stock Movement
27. Stock Age Analysis
28. Demand Sheet
29. Sales Report
30. Invoice Profitability
31. Contribution Statement
32. Loss Sales Report
33. SKU Report (Stock keeping Unit)
Contents

Stock Module Main Panel: Sub Section 1 (Master - Stock) ................................................................. 4

Product Group ................................................................................................................................. 10
Product Type ....................................................................................................................................... 12
Product UOM ....................................................................................................................................... 14
Material Issue Category ..................................................................................................................... 16
Product ................................................................................................................................................ 18
Location .............................................................................................................................................. 22
Reason ................................................................................................................................................. 25

Stock Module Main Panel: Sub Section 2 (Transaction - Stock) ........................................................ 27

Purchasing ........................................................................................................................................... 28
Purchase Requisition .......................................................................................................................... 28
Purchase Order (General) .................................................................................................................... 32
Purchase Order (Delivery) .................................................................................................................... 35
Goods Received Note ........................................................................................................................... 38
Good Return Note ............................................................................................................................... 44

Sales .................................................................................................................................................... 46
Quotation .............................................................................................................................................. 46
Sales Order ......................................................................................................................................... 50
Invoice ............................................................................................................................................... 52
Dispatch ............................................................................................................................................. 56
Sales Return with Invoice .................................................................................................................... 57
Sales Return Without Invoice .............................................................................................................. 59

Other .................................................................................................................................................. 62
Inter Location Stock Transfer ............................................................................................................. 62
Issue ................................................................................................................................. 68
Adjustments ...................................................................................................................... 74
Stock Module Main Panel: Sub Section 3 (Reports - Stock) .............................................. 82
Purchasing .......................................................................................................................... 83
Purchase Requisition Details ............................................................................................ 83
Pending PO Listing ............................................................................................................. 84
Sales .................................................................................................................................... 86
Invoice Profitability .......................................................................................................... 86
Sales .................................................................................................................................... 87
Dispatch Detail .................................................................................................................... 89
Price List ............................................................................................................................ 90
Stocks .................................................................................................................................. 91
Bin Card ............................................................................................................................... 91
Location Stock Details ....................................................................................................... 92
Stock Balance ..................................................................................................................... 92
Age Analysis ..................................................................................................................... 94
Re-Order ............................................................................................................................. 95
Stock Movement ............................................................................................................... 96
Audit Trails ......................................................................................................................... 97
System Main Panel: Administration (Sub Section 1 : Master Files) .................................. 98
Tax Codes .......................................................................................................................... 99
Tax Combination ................................................................................................................. 100
Currency ............................................................................................................................ 103
Daily Currency ................................................................................................................... 104
Price Level .......................................................................................................................... 106
Card Type .......................................................................................................................... 108
User Wise Cost Centre Allocation ..................................................................................... 110
User Wise Location Allocation ........................................................................................................ 112

System Main Panel: Administration (Sub Section 2 : System Maintenance).......................... 115
Company Profile .................................................................................................................................. 116
Backup Data Files ............................................................................................................................... 116
Change Password .............................................................................................................................. 117

Shipments Costing Main Panel: Sub Section 1 (Master Files)................................................. 119
HS Code ........................................................................................................................................ 120
Charge Category ............................................................................................................................... 121
Charge ............................................................................................................................................. 123

Shipments Costing Main Panel: Sub Section 2 (Transaction).................................................... 126
LC Opening Entry ............................................................................................................................. 127
Proforma Invoice ............................................................................................................................. 128
Commercial Invoice ....................................................................................................................... 131
Bill of Lading .................................................................................................................................. 134
Other Charges ................................................................................................................................. 136
Customs Duty Entry ......................................................................................................................... 139
Cost Process ................................................................................................................................... 142
Good Received Note ....................................................................................................................... 143

Shipments Costing Main Panel: Sub Section 3 (Reports)........................................................... 146
GIT Balance .................................................................................................................................... 147
Stock Module Main Panel: Sub Section 1
(Master - Stock)
Common Functional Key Options

- **New** - When a new entry is to be inserted the System User should begin with clicking NEW for new entries
- **Edit** - This function key is used for Editing existing entries in the system
- **Delete** - This function key is used for Deletion of existing entries
- **Undo** - This functional key is used to Undo inserted entries
- **Top** - This functional key is used to view the very first entry made
- **Previous & Next** - This functional key is used to view past entries in the system
- **Bottom** - This functional key is used to view the very last and most recently inserted entry
- **Print** - This functional key is used to Print entries made under the Section/Sub Section
- **Filter** - This functional key is used to filter and select specific entries inserted into the system
- **Sort** - This functional key is used to sort entries by category, date or by user defined sort listing
- **Find** - This functional key is used to find a specific entry
- **List** - This functional key is used to view all entries in order to view all entries made in one window pane
- **Save** - This functional key is used to save inserted data into the database
- **Close** - This functional key is used to close the opened window pane
- **View** – This function key is used to view one particular entry in order to view one by one

Common Areas of the Master Files.

- **Master Codes** are **Unique**, it cannot be **Duplicated**
- **Master Stock Entries** cannot be **Delete** if it is already in **Process** or it has been used in the system.
- When **Editing** an **Entry**, **User** cannot **Edit** the **Master Codes** of the master stocks
- **Codes** are **Mandatory** in the **Master Stocks**, so user must insert the codes.
- **Only** the **Active Master Stocks** are allowed to go further or allowed to used in other Entries.
- **User** will be able to **Tick the Active Status** in the **Master Stocks** to **Active** the particular entry
Common Areas of the Transaction.

- When **User** inserted a **Record**, the user will be getting auto generated **Reference No.**
- When it comes to **Editing**, user cannot edit the **Reference Number** it is auto generated.
- When user inserting the **Date**, User must insert transaction Date within a **Transaction Period** and **Financial Year**
- Transaction Date is **Mandatory**.
- **Manual Reference No** and **Remarks** are not **Mandatory**.
- Currency Code must exist in **Currency Master Stock**.
- Once the currency code is selected the relevant **Exchange Rate** which is equal or closest to the transaction date (to be found in the system) would automatically be filled to the Exchange Rate. If “LOCAL” currency system exchange rate will be disable and Base currency exchange will be filled automatically. If “Foreign”, currency system could enter a relevant exchange rate, but the exchange rate should be within a specific range define in the system.
- Location must exist in **Location Master file** and user must have **access rights**.
- If the user is assigned with a **Default location**, it will be filled automatically when transactions are entered. Once **Location** is selected the Name is displayed.
- Cost Centre must exist in **Cost Centre Master file** and user must have the **Access**
- If the user is assigned with a **Default Cost Centre**, it will be filled automatically when transactions are entered. Once Cost Centre is selected the Name is displayed.

Common Areas of the Grid.

- **Product Code** must exist in the **Product Master File**, So user will be able to select a product by double clicking the product field.
- Then user will be able to get the product name and unit of measure, it will be **Auto Filled**.
- **Value of a line item after reducing discount and including tax**.
- When Double clicking on **QOH** Column, user can view all the locations wise QOH details for the relevant Product, Cannot Edit
- User must enter discount Percentage within **0-100%**
- User Cannot Edit **Total Discount**, **Total Tax** and **Total Value**
• User will get a popup message when the mentioned fields are skipped in grid. This will be common for every grid in this System, so users cannot keep the Mandatory Fields Empty. Sometimes Mandatory Fields can be different for other grids. If User wants to continue the process, user can click Yes so the Entry will be Saved.

• User will be able to choose relevant Tax Codes from Combinations, that this will be based on the tax Calculation in the Tax Combination.

• User Cannot Edit Total Discount, Total Tax and Total Value

• When User Create a Tax Combination that as below, The User will be getting the output (Forward Tax) as the given Example.

Tax Combination Detail File (With Sample data)

<table>
<thead>
<tr>
<th>Tax Combination Code</th>
<th>Tax Code</th>
<th>Tax Percentage</th>
<th>Tax Rate</th>
<th>Sequence</th>
</tr>
</thead>
<tbody>
<tr>
<td>NBTVAT</td>
<td>VAT</td>
<td>2.5%</td>
<td>2.5%</td>
<td>1</td>
</tr>
<tr>
<td>NBTVAT</td>
<td>NBT</td>
<td>15%</td>
<td>15.00%</td>
<td>2</td>
</tr>
</tbody>
</table>

Discount Amount (D) ----→ ((Quantity * Price) * Discount % / 100)

Value for Tax (VT) ----→ ((Quantity * Price) – D)

Handing Combine of Taxes

Tax Amount (VAT) ----→ (VT * Tax Rate /100)

Calculate individual tax amount as above mention formula and add all different taxes to arrive with final line item total tax

Line item total tax (T) = VAT + NBT +........etc

Example

Quantity ----→ 10
Price ----→ 100
Discount % ----→ 2%
Discount amount (D) ----→ (10* 100) * 2/100) = 20
Value for Tax (VT) ----→ (10* 100) - 20 = 980
VAT Amount

\[ (980 \times 2.5\%) = 24.5 \]

NBT Amount

\[ (980 \times 15\%) = 147 \]

Line item tax amount (T)

\[ 24.5 + 147 = 171.5 \]

- The Following Example is a **Reverse Tax** Combination, Total Tax Amount will be calculated as VAT Amount+ NBT Amount

\[
\begin{align*}
\text{NBT} & \quad 2.5 \\
\text{VAT} & \quad 15.00 \\
\end{align*}
\]

<table>
<thead>
<tr>
<th>Quantity</th>
<th>10.00</th>
</tr>
</thead>
<tbody>
<tr>
<td>Price</td>
<td>117.50</td>
</tr>
<tr>
<td>Discount %</td>
<td>2.00</td>
</tr>
</tbody>
</table>

\[
\begin{align*}
\text{Gross Value} & \quad 1,175.20 & (\text{Price} \times \text{Quantity}) \\
\text{Discount} & \quad 23.50 & (\text{Value} \times \text{Discount} \%) \\
\text{Value} & \quad 1,151.50 & (\text{Gross Value} - \text{Discount}) \\
\end{align*}
\]

\[
\begin{align*}
\text{VAT Amount} & \quad 147.78 & (\text{Value} \times \text{VAT})/(\text{VAT+NBT+100}) \\
\text{NBT Amount} & \quad 24.50 & (\text{Value-VAT Amount} \times \text{NBT})/(\text{NBT+100}) \\
\end{align*}
\]

- The Tax Combination for the sales Transaction as following. If User select **Yes** option Status, The Output will be shown in below example. Normally the Status Yes, will show/Print the complete Tax Calculations of the Tax Amount for the Client.

<table>
<thead>
<tr>
<th>Tax Combination Code</th>
<th>Tax Code</th>
<th>Tax Percentage</th>
<th>Tax Rate</th>
<th>Sequence</th>
</tr>
</thead>
<tbody>
<tr>
<td>NBTVAT</td>
<td>VAT</td>
<td>2.5%</td>
<td>2.5%</td>
<td>1</td>
</tr>
<tr>
<td>NBTVAT</td>
<td>NBT</td>
<td>15%</td>
<td>15%</td>
<td>2</td>
</tr>
</tbody>
</table>

Total Tax Amount will be displayed based on the customers Tax Status.

**Scenario 1 :**

- **If Tax status is “Yes”, Tax amount is calculated and displayed on the printout.**

\[
\begin{align*}
\text{Discount Amount (D)} & \quad (((\text{Quantity} \times \text{Price}) \times \text{Discount} \%) / 100) \\
\text{Value for Tax (VT)} & \quad (((\text{Quantity} \times \text{Price}) - \text{D}) \\
\end{align*}
\]

**Handling Combine of Taxes**
Tax Amount (VAT) \( \rightarrow (VT \times \text{Tax Rate}/100) \)

Calculate individual tax amount as above mention formula and add all different taxes to arrive with final line item total tax

Line item total tax \( (T) \) = VAT + NBT + ……etc

Line item total = \((VT + T)\)

Example

| Quantity | 10 |
| Price | 100 |
| Discount % | 2% |

Discount amount \( (D) \) \( \rightarrow (10 \times 100) \times 2/100) = 20 \)

Value for Tax \( (VT) \) \( \rightarrow (10 \times 100) - 20 = 980 \)

VAT Amount \( \rightarrow (980) \times 2.5/100 = 24.5 \)

NBT Amount \( \rightarrow (980) \times 15/100 = 147 \)

Line item tax amount \( (T) \) \( \rightarrow 24.5 + 147 = 171.5 \)

Line item total \( \rightarrow 980 + 171.5 = 1151.5 \)

- If TAX status is “NO”, TAX amount is calculated and not displayed on the printout but sales price should contain the tax portion. (Tax inclusive selling price). Print discount amount is different than the actual. Total Tax Amount will be calculated as \(((\text{Unit Price} \times \text{Quantity}) - \text{Discount Value})\)

Scenario 2 :

All actual value are as Scenario 1.

All different taxes will be added to the tax exclusive price to arrive with Tax inclusive

Sales Price \( (SI) \)

Sales Price inclusive Tax \( (SI) \) \( \rightarrow (SI \times \text{Quantity}) + (\text{TAX1} + \text{TAX2} + \ldots \ldots \ldots \) etc)/ Quantity

Line Item Print Discount \( (PD) \) \( \rightarrow ((SI \times \text{Quantity}) \times \text{Discount \% }/ 100) \)

Example

| Quantity | 10 |
| Sales Price \( (SE) \) | 100 |
| Discount % | 2% |

VAT Amount \( \rightarrow (100 \times 10) \times 2.5/100 = 25 \)
NBT Amount

\[(100 \times 10) \times \frac{15}{100} = 150\]

Total Tax Value (TV)

\[25 + 150 = 175\]

Unit Price

\[117.50\] (Price + (Total Tax/Quantity))

1 Discount

\[2.35\] (Unit Price \times \frac{2}{100})

Discount Value

\[23.50\] (1 Discount \times Quantity)

- User cannot enter backdated transactions to the selected location and selected items, the below pop up message will appear, when user tries to edit or add a backdated transaction. This will be affected to the Good Received Note, Good Return Note, Transfer Note, Transfer Confirmation, Issue Note, Issue Return with Issue and Issue Return without Invoice.

Product Group

Item group is used to manage products by dividing products items into groups by giving a Group Code and Group Name.
Upon clicking New the system user will be prompted to insert a Unique Group Code upon which the System User must Assign a Group Name, upon filling both fields the System User may click Save to insert the entry into the system.

**Action Flow:**

New ➔ Group Code ➔ Group Name ➔ Click Save Icon

When it comes to Editing an entry in Item Group, the user will be able to edit an Entry. User must select Edit and then user can edit the Group Name as above Image. User can only Edit or make changes to the Group Name and then user must click Save. User cannot edit the Group Code, that cannot be Edited or Changed.
Action Flow:

Edit Icon ➔ Edit the Group Name ➔ Click save Icon

In the case of **Deleting** an entry the user must select **Delete**, upon which the user will be prompted to select **Yes** or **No**. If the user wanted to **delete** the Entry, then select Yes, and the Entry will be deleted as **above Image**.

**Action Flow:**

Delete Icon ➔ Select Yes ➔ Deleted

**Product Type**

An item type is a classification for items that indicates how you order and stock a particular item at your company.
Upon clicking **New** the system user will be prompted to insert a **Unique Type Code** upon which the System User must Assign a **Type Name**, upon filling both fields the System User may tick the Active Status and then click **Save** to insert the entry into the system.

**Action Flow:**

New → Type Code → Type Name → Status Click → Save Icon

When it comes to **Editing** an entry in Item Type, the user will be able to edit an Entry. User must select **Edit** and then user can edit the **Type Name and Status** as **above Image**. User can only Edit or make changes to the mentioned Fields and then user must click **Save**. User cannot edit the Type Code, that cannot be Edited or Changed.
Action Flow:

Edit Icon ➔ Edit the Type Name/Status ➔ Click Save Icon

In the case of **Deleting** an entry the user must select **Delete**, upon which the user will be prompted to select **Yes** or **No**. If the user wanted to **delete** the Entry, then select Yes, and the Entry will be deleted as above Image.

Action Flow:

Delete Icon ➔ Select Yes ➔ Deleted

**Product UOM**

Unit of measure is assigned to all inventory items and must be defined before a product can be entered. Each product will have a stocking unit of measure, sales ordering unit of measure and a purchasing unit of measure.
Upon clicking **New** the system user will be prompted to insert a **Unique Unit of Measure Code** upon which the System User must Assign a **Unit of Measure Name**, upon filling both fields the System User may tick the Active Status and then click **Save** to insert the entry into the system.

**Action Flow:**

New ➔ Unit of Measure Code ➔ Unit of Measure Name ➔ Status ➔ Click Save Icon

When it comes to **Editing** an entry in Item UOM, the user will be able to edit an Entry. User must select **Edit** and then user can edit the **Unit of Measure Name and Status** as above. **Image.** User can only Edit or make changes to the mentioned Fields and then user must click **Save.** User **cannot edit Unit of Measure Code**, that cannot be Edited or Changed.
Action Flow:

Edit Icon → Edit the Unit of Measure Name/Status → Click Save Icon

In the case of **Deleting** an entry the user must select **Delete**, upon which the user will be prompted to select **Yes** or **No**. If the user wanted to **delete** the Entry, then select Yes, and the Entry will be deleted as **above Image**.

**Action Flow:**

Delete Icon → Select Yes → Deleted

**Material Issue Category**

The Material issue category master stock must use the material issue category code, Material Issue Description and Issue type must exist.
Upon clicking **New** the system user will be prompted to insert a **Unique Material Issue Category Code** upon which the System User must Assign a **Material Issue Description** and User will be able to select a Issue Type upon filling above fields the User may tick the Active Status and then click **Save** to insert the entry into the system.

**Action Flow:**

New ➔ Material Issue Category Code ➔ Material Issue Description ➔ Issue Type ➔ Status ➔ Click Save Icon

Note: Material Issue Category Code, Material Issue Description and Issue Type are Mandatory. User must fill these fields.
When it comes to **Editing** an entry in Material Issue Category, the user will be able to edit an Entry. User must select **Edit** and then user can edit the **Material Issue Description**, **Issue Type and Status** as **above Image**. User can only Edit or make changes to the above mentioned Fields and then user must click **Save**. User **cannot edit Material Issue Category Code**, that cannot be Edited or Changed.

**Action Flow:**

Edit Icon —> Edit the Material Issue Description/Issue Type/Status —> Click SaveIcon

In the case of **Deleting** an entry the user must select **Delete**, upon which the user will be prompted to select **Yes** or **No**. If the user wanted to **delete** the Entry, then select Yes, and the Entry will be deleted as **above Image**.

**Action Flow:**

Delete Icon —> Select Yes —> Deleted

**Product**

Items are the products that company sell or services that you render to various clients and that can be purchased from various vendors in a business.
Upon clicking New, the User will able to Insert the **Product Code** and then proceed to fill the information as the **Product Name**, then User can double click these Fields to select a predefined **Product Group**, **Product type**, **Product Category**, **Tax Combination**, **Product UOM**, **Issue Type**, **Reorder Level**.

User will be able to add images to the product by clicking the add Icon below the Master File. If user select FIFO or Batch issue type, user can tick the Available option. Then User can insert a Pack Size for the particular product.

Mandatory Fields in this Item master stocks are **Product Code**, **Product Name**, **Product Group**, **Product type**, **Product Category**, **Tax Combination**, **Product UOM**, **Issue Type**, **Reorder Level**.

Upon clicking New, the User will able to Insert the **Product Code** and then proceed to fill the information as the **Product Name**, then User can double click these Fields to select a predefined **Product Group**, **Product type**, **Product Category**, if these fields are Empty the user will not be able to continue the process, a pop-up message box will be appeared for each mentioned field as below,
These popup messages will be appeared when the user keeps the must fields empty. These are common error messages to all the must/Mandatory fields in the system.

Then user can insert **Remarks** in the details Section on General Tab. Then User can select the Product Status, Select **Tax Combination, Product UOM** and then user can insert Re Order Level, Quantity, select a HS Code, then use will be able to select an **Issue Type** among,

- **FIFO** (First-In, First-Out) - The oldest inventory items are sold/issue first. The cost of goods purchased first (first-in) is the cost of goods sold/issue first (first-out).
- **Serial** - If an item is marked as a serial item, required to enter the serial number for each individual unit received AND select that serial number when the unit is sold/issue.
- **Batch** - If an item is marked as a batch item, received new lot keep as a new batch AND select that batch number when the unit is sold/issue.

Tax Combination, Product UOM and Issue Type fields cannot be Empty.

Then the Expiry Date will be available if it is a batch issue type. and if user wants to add or insert an image to the product by clicking the add image icon and in the Other Section on Details Tab. In the Sales Pricing Tab, User will be able to select Price Level that is Default and then can insert the Price of the Product like the below Image. Then user can proceed to Save those details.
Action Flow:

New → Product Code → Product Name → Product Group → Product Type → Product Category → Remarks → Product Status → Tax Combination → Product UOM → Re-Order Level → Quantity → HS Code → Issue Type → Expire Date → Sales Pricing → Price Level → Click Save Icon

When it comes to Editing an entry, the user will be able to edit an Entry. User must select Edit and then user can edit the Product Name, Product Type, Remarks and can edit all the fields that is under the Details Section as below Image, then in the Other Section user will be able to edit Product Status, Tax Combination, Reorder Level, Reorder Quantity, HS Code and User can make changes to the sales pricing tab fields. User can only Edit or make changes to the mentioned fields and then user must click Save. User cannot edit the Product Code and Category in this Item Stock, that cannot be Edited or Changed.

Action Flow:

Edit Icon → Edit the Fields that is needed to be Edited → Click Save Icon
In the case of **Deleting** an entry the user must select **Delete**, upon which the user will be prompted to select **Yes** or **No**. If the user wanted to **delete** the Entry, then select Yes, and the Entry will be deleted as **above Image**.

**Action Flow:**

Click Delete Icon → Select Yes → Deleted

**Location**

Location is a space you lease for the selling of goods to consumers. In business retailers have one overall goal: to sell merchandise. Locations can be varying according to your business it can be a store located inside the factory, a van, an outlet, etc.
Upon clicking New, the User will be able to Insert the **Location Code** and then proceed to fill the information as the **Location Name**, **Telephone No**, **Fax No.**, **Email**, **Location Type** and **Status**.

- Locations Types are predefined as per the business of the company. If the User wants to insert the address Details then user can go to the Tab Address Details and insert the information. Then user can proceed to Save those details.
- Before using this location in the entries users need to gain access to this location through Location Access Permission Entry in the Administration Module.

User will be able to select a predefined Location Type by Double clicking the Location Type Field, - Stores
- Damage Stores
- Sales
Action Flow:

New → Location Code → Location Name → Telephone No → Fax No. → Email → Location Type → Status → Click Save Icon

When it comes to Editing an entry in Location, the user will be able to edit an Entry. User must select Edit and then user can edit the All the Fields as above Image but User cannot make changes to the Location Code & Location Type. Then user must click Save.

Action Flow:

Edit Icon → Edit the wanted Fields → Click save Icon

In the case of Deleting an entry the user must select Delete, upon which the user will be prompted to select Yes or No. If the user wanted to delete the Entry, then select Yes, and the Entry will be deleted as above Image.

If the user already Used or if it is already in Process, then the user cannot delete the entry. As below Image an error message will be appear, Same goes to the other Master Files.
**Action Flow:**

Click Delete Icon → Select Yes → Deleted

**Reason**

Reason is a classification for item transactions that is to insert, what is the reason as the description and what kind of reason type that indicates the reason of a particular transaction at your company.

Reason Code, Reason Description, Reason Type are Mandatory, User must Fill the fields.

User will be able to select a predefined Reason Type by Double clicking the Reason Type Filed

- Damage Reason Types
- Sales Return Reason Types
- Adjustment Reason Types
Upon clicking New, the User will able to Insert the **Reason Code** and then proceed to fill the information as the **Reason Description**, then user will be able to double click the **Reason Type** field and select a reason type and **Status**.

**Action Flow:**

New → Reason Code → Insert Reason Description → Reason Type → Status →

Click Save Icon

When it comes to **Editing** an entry in Reason, the user will be able to edit an Entry. User must select **Edit** and then user can edit the **Reason Description Field** as above Image. Then user must click **Save**.

**Action Flow:**

Edit Icon → Edit the Description Field → Click save Icon

In the case of **Deleting** an entry the user must select **Delete**, upon which the user will be prompted to select **Yes** or **No**. If the user wanted to **delete** the Entry, then select Yes, and the Entry will be deleted as above Image.

**Action Flow:**

Click Delete Icon → Select Yes → Deleted
Stock Module Main Panel: Sub Section 2
(Transaction - Stock)
Purchasing

Purchase Requisition

A Purchase requisition is a request that is made to the purchasing organization to procure a certain list of materials/products.

Upon Clicking **New** the user will be able to Insert a Manual No., then user will be able to select a predefined cost Centre by double clicking the cost centre field, user will be able to add Remarks.

- When it comes to inserting date, there is a data entry Period that is in the Company Profile, so when the user tries to enter the date that is not in the data entry period then the below popup box will appear, this will be common for every Transactions.
When User enter the date before the Account Period then the following popup box will appear. This is common for every Transactions.

So, User must enter the valid data to the Date and users can continue the transaction. In the above grid field, user can double click and select Product Code and enter the quantity of that particular product. Upon filling these fields, the user may click Save. Then popup message box will appear as to select an option to send this transaction for the approval. which user can select Yes/No option. As below Image,

**Action Flow:**
- New → Manual No. → Cost Centre → Remarks → Product Code → Quantity →
- Click Save Icon → Select Yes/No
When it comes to **Editing** an entry in Purchase Requisition, the user will be able to edit an Entry. User must select **Edit** and then user can select a predefined **Reference No.** and then edit the **Cost Centre, Remarks, Product Code and Quantity** as above Image. User can only Edit or make changes to the above mentioned Fields and then user must click **Save**.

**Action Flow:**

Edit Icon → Reference No. → Edit the Needed Fields → Click Save Icon

In the case of **Deleting** an entry the user must select **Delete**, then user will be able to select a Predefined **Reference No.** and upon which the user will be prompted to a popup message that to enter a Reason to Delete the Entry as above Image. After Entering a Reason, User will be able to Click OK and that particular Entry will be Deleted. When User didn't enter any Reason then below popup Message will appear and user won't be able to delete the Entry.
Action Flow:
Delete Icon → Reference No. → Enter a Reason → Select OK → Deleted

If the user wants to view the approve details in the purchase requisition, then user can click the approve Icon, the user can double click the Reference No. Field and select a predefined Entry and then the details of that particular one will be appeared.

After the Entry Details appeared, the user can click save an option box will appear and user can select Yes/No. Like above Image, if user select Yes option and then that particular Entry will be approved, if No then the entry will not go further.

Action Flow
Approve Icon → Reference No. → Details Appeared → Click save Icon → Select Yes → Approved
When the user wants to View an entry that is already inserted, then user can click the View icon, by clicking the view in this Purchase requisition an option box will appear that is to click Yes/No. If the user click yes then the user will be able to view approved Entries. If the user clicks No then Unapproved Entries can be viewed by the user. As Below Image,

![Image of the view option box](image)

After Selecting an option then insert the **Reference No.** of the entry that user wants to view and then the entry details will be displayed. User can only View the entries as below.

![Image of the purchase order view](image)

**Purchase Order (General)**

Purchase Order provides a way for a buyer to place an order, this process provides after a purchase requisition has been made and passed the approval process. Documents sent from a buyer to a supplier with a request for an order
Upon Clicking **New** the user will be able to Insert a Manual No., then user will be able to select a Currency Code, predefined Supplier Code, Cost Centre and Tax Combination by double clicking these fields, user will be able to add Remarks.

- In the above grid field, user can double click and select Purchase Req. No and then the selected Req. No Products will be displayed in the below grid as above Image. Value must be in selected currency
- User will be getting a popup box, after the user entered the Quantity as below Image, User can enter the quantity for the displaying product(s).
Upon filling these fields, the user may click Save. When user skip to add Items then an error message will be popup as below,

Then popup message box will appear as to select an option to send this transaction for the approval. which user can select Yes/No option. As below Image,
Purchase Order (Delivery)

In this Sub Section tab under the Purchase Order "Delivery" the user will be prompted to enter a Location Code while the other fields are about the delivery details as Contact Person, Delivery Address and the Telephone No.

**Action Flow:**

1. New → Manual No. → Currency Code → Double Click Supplier Code → Cost Centre → Cost Centre
2. Tax Combination → Purchas Req. No./ Double Click the Product Code in the Grid →
3. Click Delivery Tab → Insert data in to primary fields → Click Save Icon
When it comes to Editing an entry in Purchase Order, the user will be able to edit an Entry. User must select Edit and then user can Select a predefined Reference No. and then edit the, Currency Code, Supplier Code, Cost Centre, Tax Combination, Remarks, Product Code and Quantity as above Image and user will be able to edit the delivery tab fields as well. User can only Edit or make changes to the above mentioned Fields and then user must click Save.

Action Flow:

Edit Icon ➔Reference No. ➔Edit the Needed Fields ➔Click Save Icon

In the case of Deleting an entry the user must select Delete, then user will be able to select a Predefined Reference No. and upon which the user will be prompted to a popup message that to enter a Reason to Delete the Entry as above Image. After Entering a Reason, User will be
able to Click OK and that particular Entry will be Deleted. When User didn't enter any Reason then popup Message will appear and user won't be able to delete the Entry.

If the user wants to view the approve details in the purchase order, then user can click the approve Icon, the user can double click the Reference No. Field and select a predefined Entry and then the details of that particular one will be appeared.

![Do you want to approve this record?](image)

After the Entry Details appeared, the user can click save an option box will appear and user can select Yes/No. Like above Image, if user select Yes option and then that particular Entry will be approved, if No then the entry will not go further.

**Action Flow**

Approve Icon → Reference No. → Details Appeared → Click save Icon → Select Yes → Approved

When the user wants to View an entry that is already inserted, then user can click the View icon, by clicking the view in this Purchase Order an option box will appear that is to click Yes/No. If the user click yes then the user will be able to view approved Entries. If the user clicks No then Unapproved Entries can be viewed by the user. As Below Image,

![Do you want to view Approved Transaction?](image)

After Selecting an option then insert the Reference No. of the entry that user wants to view and then the entry details will be displayed. User can only View the entries as below.
Goods Received Note

GRN known as Good Received Note, by confirming that the items have been received as expected that is accordance with the original order, and that the items can therefore be invoiced by supplier and subsequently paid for. This will be internal evidence of goods received to process and match against your supplier invoices/purchase orders.
Upon Clicking **New**, the user will have the option of selecting a **Purchase Order No** and then select a **Location Code**, **Remarks**.

- When a PO is selected the all information will be load into the GRN entry. Supplier code will be disabled. If PO is empty the user can enter a GRN without a related PO.
- user can select a product and then the Product Details will be appear as above Image. User can select a Quantity for the product, and when user double Click the quantity field a popup box will appear.
- When user select a product that is as Batch, the below Image pop up box will appear,
On the above popup box user **must enter** values for all the fields as Batch No, Quantity, Cost Price, Manufacture Date and Expire Date.

When User select a product that is a Serial Type then a below popup box will appear. In this popup box, user can select Serial Numbers Auto Generated option or he/she can Enter serial numbers manually as below Image. Then User can Update the Price and click the Tick button.
Upon insertion all the data in the above popup box user can click the Tick button. So those information will be added. Then user may proceed to **Save** the entry, by saving it gives a **Reference No.**

The Configuration scenarios of the GRN, This will be managed based on the configuration File,

- Purchase order is must to the GRN
- Accept more than PO quantity
- Receive new items not in the purchased order.
- Facility to edit the cost price in the GRN(with PO).

**Action Flow**

New ➔ Purchase Order No ➔ Location Code ➔ Remarks ➔ Product Code ➔ Quantity ➔ Enter values in Popup Box ➔ Click Save Icon
When it comes to **Editing** an entry in Good Received Note, the user will be able to edit an Entry. User must select **Edit** and then user can Select a predefined **Reference No.** and then edit the , **Manual No, Tax Combination, Remarks,** as **above Image.** User can only Edit or make changes to the above mentioned Fields and then user must click **Save.**

**Action Flow:**

Edit Icon ➔ Reference No ➔ Edit the Tax Combination/Remarks/Manual No. ➔ Click Save Icon

In the case of **Deleting** an entry the user must select **Delete,** then user will be able to select a Predefined **Reference No.** and upon which the user will be prompted to a popup message that to enter a Reason to Delete the Entry as **above Image.** After Entering a Reason, User will be able to Click OK and that particular Entry will be Deleted. When User didn't enter any Reason then popup Message will appear and user won't be able to delete the Entry.

**Action Flow**

Delete Icon ➔ Reference No ➔ Select Yes ➔ Record Deleted

If the user wants to view the approve details in the Good Received Note, then user can click the approve Icon, the user can double click the **Reference No.** Field and select a predefined Entry and then the details of that particular one will be appeared.
After the Entry Details appeared, the user can click save an option box will appear and user can select Yes/No. Like above Image, if user select Yes option and then that particular Entry will be approved, if No then the entry will not go further.

**Action Flow**

Approve Icon → Reference No. → Details Appeared → Click save Icon → Select Yes → Approved

When the user wants to View an entry that is already inserted, then user can click the View icon, by clicking the view in this Good Received Note an option box will appear that is to click Yes/No, if the user click yes then the user will be able to view approved Entries. If the user clicks No then Unapproved Entries can be viewed by the user. As Below Image,

After Selecting an option then insert the Reference No. of the entry that user wants to view and then the entry details will be displayed. User can only View the entries as below.
Good Return Note
A Goods Return Note acts as a receipt for the customer to show that company have received back an item.

In the Good Return Note Upon Clicking **New**, the user will have the option of Inserting a **Manual No.** and then select a currency code, Supplier Code, Location Code and remarks.

- Quantity cannot go greater than the quantity on hand. When user insert a greater quantity and then popup box will appear as below Image. This is common for every stock. The Purchase Price in the grid will be picked From the GRN, User cannot Edit.
- GRN No. will be displayed based on the given Supplier and Location Code, and then Product code will be taken from that particular GRN No.

![Image of the Goods Return Note feature](image-url)
In the Grid, User Cannot Return more than GRN Balance Quantity. For an Example, If the GRN Balance is 5, User cannot exceed the quantity more than 5.

In the below Image, when user double click the Quantity field a popup box will appear as below. User can select Serial Numbers. Users cannot assign more than No. of Quantity. Upon insertion all the data the user may proceed to Save the entry, by saving it gives a Reference No.

Action Flow

New → Manual No. → Currency Code → Supplier Code → Location Code → GRN No. → Product Code → Click Save Icon

When the user wants to View an entry that is already inserted, then user can click the View icon, by clicking the view in this Good Returns Note, then insert the Reference No. of the
entry that user wants to view and then the entry details will be displayed. User can only View the entries as below.

Action Flow

View ➔Reference No. ➔ Details Appeared

Sales

Quotation

The sales quotation is generated to ensure that a specific quantity of product will be delivered at a specific time period and at a specific price.
Upon Clicking **New** the user will be able to Insert a Manual No., then in the quotation details, user will be able to select a Currency Code, Tax Status predefined Customer Code, Sales Rep, Cost Centre by double clicking these fields, user will be able to add Terms. If TAX status is “Yes” Tax code assigned for product will be used to calculate the TAX amount and displayed on the quotation.

- If “No” TAX will be calculated but will not be displayed on the quotation.
- In the above **grid** field, user can double click and select Product Code and Products will be displayed in the below grid as above Image. Then enter the quantity of that particular product. Upon filling these fields,
In Customer Information tab, which the user can enter customer information such as Contact person, Address then the user may click Save. When user skip to add Items then an error message will be popup.

**Action Flow**

New ➔ Manual No ➔ Select a Date ➔ Currency Code ➔ Tax Status ➔ Customer Code ➔ Sales Rep ➔ Cost Centre ➔ Terms ➔ Location Code ➔ Remarks ➔ Product Code ➔ Customer Information Tab ➔ Click Save Icon
When it comes to **Editing** an entry in Quotation, the user will be able to edit an Entry. User must select **Edit** and then the user can Select a predefined **Reference No.** and then user can edit the Manual No., Tax Combination, Remarks, Quotation Details Section, Location Details Section as **above Image**. User can only Edit or make changes to the above mentioned Fields and then user must click **Save**. User cannot edit or Delete the Quotation if that particular quotation has been allocated to a Sales Order or Invoice. Popup Message will appear as below, this will be a common validation to the Sales Transaction Stock.

**Action Flow:**

Edit Icon ➔ Reference No. ➔ Edit the Needed Fields ➔ Click Save Icon
In the case of **Deleting** an entry the user must select **Delete**, then user will be able to select a Predefined **Reference No.** and upon which the user will be prompted to a popup message that to enter a Reason to Delete the Entry as **above Image**. After Entering a Reason, User will be able to Click OK and that particular Entry will be Deleted. When User didn't enter any Reason then popup Message will appear and user won't be able to delete the Entry.

**Action Flow**

Delete Icon ➔ Reference No. ➔ Select Yes ➔ Record Deleted

**Sales Order**

Sales Order is generated by the seller, indicating that the customer is ready to purchase products. It is a confirmation document that authorizes sale of listed items for the given amount. The document gives a clear understanding about what the customer has decided to buy. The seller generates SO when the sales quote sent to the customer is approved.

**Date, Quotation No, Currency Code, Customer Code, Sales Rep, Cost Centre, Tax Status, Location Code and the grid are Mandatory Fields, User must fill the fields.**
Upon Clicking **New** the user will be able to Insert a Manual No., then in the Quotation/Sales Order Details, user will be able to select a Quotation No, Tax Status predefined Currency Code, Customer Code, Sales Rep, Cost Centre by double clicking these fields, user will be able to add Terms. After inserting the quotation Details, user must select a Location Code, user will be able to insert Remarks.

- In the above **grid** field, user can double click and select Product Code and Products will be displayed in the below grid as above Image. Then enter the quantity of that particular product.
- Upon filling these fields, In Customer Information tab, which the user can enter customer information such as Contact person, Address then the user may click Save. When user skip to add Items then an error message will be popup.
- In the grid Sales Price cannot be edited,
- For the grid Sales details refer to the **Common Area of Grids Section**.

**Action Flow**

New ➔ Manual No. ➔ Select a Date ➔ Quotation Code ➔ Currency Code ➔ Tax Status ➔ Customer Code ➔ Sales Rep ➔ Cost Centre ➔ Terms ➔ Location Code ➔ Remarks ➔ Product Code ➔ Customer Information Tab ➔ Click Save Icon
When it comes to **Editing** an entry in Sales Order, the user will be able to edit an Entry. User must select **Edit** and then user can Select a predefined **Reference No.** and then edit the, **Manual No., Tax Combination, Remarks, Cost Centre, Location Code** as above Image. User can only **Edit** or make changes to the above mentioned Fields and then user must click **Save**.

**Action Flow:**

Edit Icon ➔ Reference No. ➔ Edit the Needed Fields ➔ Click Save Icon

In the case of **Deleting** an entry the user must select **Delete**, then user will be able to select a Predefined **Reference No.** and upon which the user will be prompted to a popup message that to enter a Reason to Delete the Entry as above Image. After Entering a Reason, User will be able to Click OK and that particular Entry will be Deleted. When User didn't enter any Reason then popup Message will appear and user won't be able to delete the Entry.

**Action Flow**

Delete Icon ➔ Reference No. ➔ Select Yes ➔ Record Deleted

**Invoice**

A sales invoice is a method that a company uses to communicate to clients about the sums that are due in exchange for goods that have been sold. A sales invoice should include information about which items the customer has purchased, the quantities he has bought, discounts he has received, and the total amount he owes.
Upon Clicking **New** the user will be able to Insert a Manual No., then user can select an Invoice type,

- Direct
- Quotation
- Sales Order

After Selecting an Option as **Invoice type** then user must select a Payment Type below,

- CA
- CR

When User chose Cash (CA) as a Payment Method then user must give the details of Payments in Payment Details Tab. Which Credit (CR) Payment Method does not need any Details of Payment.
- Then in the Invoice/Quotation/Sales Order Details, user will be able to select a Exchange Rate, Tax Status predefined Currency Code, Customer Code, Sales Rep, Cost Centre by double clicking these fields.

- Then user **must** enter the quantity, Select a TT and Dispatch of that particular product. When Dispatching the product from the grid, user will be dispatching the whole product.

- User cannot save a record until the mandatory fields are empty. So users must fill or settle the fields to save the fully record.

- When user skip to add Items then an error message will be popup.

In Customer Information tab, which the user can enter customer information such as Contact person, Address and Tax Registration then the user may click Save.
After filling the Customer Information Tab, the next Tab to be filled is Payment Details Tab. It is a must when User chose Cash (CA) as a Payment Method in Payment Details Tab. User can fill the Cash Payment Section and Direct Deposit Section. Fields like Amount, Cash In Hand, Slip No, Bank Account, Cannot be Empty. Upon filling these fields, the user may click Save.

**Action Flow**

New → Manual No → Select a Date → Invoice Type → Payment Type → Tax Status → Currency Code → Exchange Rate → Customer Code → Sales Rep → Cost Centre → Location Code → Remarks → Product Code → Customer Information Tab → Payment Details Tab → Insert Value for the Fields → Click Save Icon

In the case of **Deleting** an entry the user must select **Delete**, then user will be able to select a Predefined **Reference No.** and upon which the user will be prompted to a popup message that to enter a Reason to Delete the Entry as **above Image**. After Entering a Reason, User will be able
to Click OK and that particular Entry will be Deleted. When User didn't enter any Reason then popup Message will appear and user won't be able to delete the Entry.

**Action Flow**

Delete Icon ➔ Reference No. ➔ Select Yes ➔ Record Deleted

**Dispatch**

The Dispatch that certifies the delivery of goods to the buyer, who must sign it to make it clear that the goods have been delivered in accordance with the conditions established. Especially when the exporter delivers the goods in the seller's country and he needs a document proving delivery, that is in international trades.

Upon Clicking **New** the user will be able to Insert a Manual No., then in the Invoice Details, Upon filling these fields, the user may click Save.

**Action Flow**

New ➔ Manual No. ➔ Select a Date ➔ Invoice No ➔ Remarks ➔ Click Save Icon
In the case of Deleting an entry the user must select Delete, then user will be able to select a Predefined Reference No. and upon which the user will be prompted to a popup message that to enter a Reason to Delete the Entry as above Image. After Entering a Reason, User will be able to Click OK and that particular Entry will be Deleted. When User didn't enter any Reason then popup Message will appear and user won't be able to delete the Entry.

**Action Flow**

Delete Icon → Reference No. → Select Yes → Record Deleted

**Sales Return with Invoice**

Sales Return with Invoice is about if a customer wants to return items that you have sold and received payment for, user must include enter sales return without Invoice.
Upon Clicking **New** the user will be able to Insert a Manual No., then in the Invoice Details, In the Grid, user can enter Dispatch.

**Action Flow**

New ➔ Manual No. ➔ Select a Date ➔ Invoice No ➔ Reason ➔ Remarks ➔ Click Save Icon.

Select an Invoice No and other fields will be auto generated. User will be able to insert Remarks. User must mention a Reason.

In the case of **Deleting** an entry the user must select **Delete**, then user will be able to select a Predefined **Reference No.** and upon which the user will be prompted to a popup message that to enter a Reason to Delete the Entry as **above Image**. After Entering a Reason, User will be
able to Click **OK** and that particular Entry will be Deleted. When User didn't enter any Reason then popup Message will appear and user won't be able to delete the Entry.

**Action Flow**

Delete Icon → Reference No. → Select Yes → Record Deleted

**Sales Return Without Invoice**

Sales Return without Invoice is about if a customer wants to return items that Company have sold and received payment for, that is to enter sales return without Invoice.

Upon Clicking **New** the user will be able to Insert a Manual No., then in the Invoice Details, user will be able to select a Currency Code, Customer Code, Sales Rep, Cost Centre by double clicking these fields, user will be able to select a Location Code, user will be able to insert Remarks. User must mention a Reason.
• In the above grid field, user can double click and select Product Code and Products will be displayed in the below Grid as above Image. Then enter the quantity of that particular product.
• Upon filling these fields, the user may click Save. When user skip to add Items then an error message will be popup.

Action Flow

New ➔ Manual No ➔ Select a Date ➔ Invoice No ➔ Currency Code ➔ Customer Code ➔ Sales Rep ➔ Cost Centre ➔ Location Code ➔ Reason ➔ Remarks ➔ Product Code ➔ Enter values to grid ➔ Click Save Icon

When it comes to Editing an entry in Sales Return Without Invoice, the user will be able to edit an Entry. User must select Edit and then user can Select a predefined Reference No. and then edit the , Manual No., Tax Combination, Remarks, Cost Centre, Location Code, Currency Code, Sales Rep, Reason and grid details as above Image. User can only Edit or make changes to the above mentioned Fields and then user must click Save.

Action Flow:

Edit Icon ➔ Reference No. ➔ Edit the Needed Fields ➔ Click Save Icon
In the case of **Deleting** an entry the user must select **Delete**, then user will be able to select a Predefined **Reference No.** and upon which the user will be prompted to a popup message that to enter a Reason to Delete the Entry as **above Image**. After Entering a Reason, User will be able to Click **OK** and that particular Entry will be Deleted. When User didn't enter any Reason then popup Message will appear and user won't be able to delete the Entry.

**Action Flow**

Delete Icon → Reference No. → Select Yes → Record Deleted

If the user wants to view the approve details in the Sales Return Without Invoice then user can click the approve Icon, the user can double click the **Reference No.** Field and select a predefined Entry and then the details of that particular one will be appeared.

After the Entry Details appeared, the user can click save an option box will appear and user can select **Yes/No**. Like above Image, if user select Yes option and then that particular Entry will be approved, if No then the entry will not go further.

**Action Flow**

Approve Icon → Reference No. → Details Appeared → Click save Icon → Select Yes → Approved
Other

Inter Location Stock Transfer

Transfer Requisition

Transfer Requisitions are generated when other facility creates a requisition to be sourced from a cost centre. Approval of the Transfer Requisition occurs at the cost centre that will be receiving the product, therefore no further approval is required.

Upon Clicking New the user will be able to Insert a Manual No., then in the Cost Centre/Location Details, user will be able to select a Cost Centre Requested By and Requested From, then user can insert a Remarks.

- After inserting these Details, in the above grid field, user can double click and select Product Code and Products will be displayed in the below grid as above Image. Then enter the quantity and of that particular product. Then the user may click Save.
Action Flow

New ➔ Manual No ➔ Cost Centre ➔ Cost Code ➔ Remarks ➔ Product Code ➔

Click Save Icon

When it comes to Editing an entry in Transfer Requisition, the user will be able to edit an Entry. User must select Edit and then user can Select a predefined Reference No. and then edit the , Manual No., Cost Centre, Requested By, Requested From, Remarks and can edit the product quantity as above Image. User can only Edit or make changes to the above mentioned Fields and then user must click Save.

Action Flow:

Edit Icon ➔ Reference No. ➔ Edit the Needed Fields ➔ Click Save Icon

In the case of Deleting an entry the user must select Delete, then user will be able to select a Predefined Reference No. and upon which the user will be prompted to a popup message that to enter a Reason to Delete the Entry as above Image. After Entering a Reason, User will be
able to Click OK and that particular Entry will be Deleted. When User didn't enter any Reason then below popup Message will appear and user won't be able to delete the Entry.

**Action Flow**

Delete Icon ➔ Reference No. ➔ Select Yes ➔ Record Deleted.

If the user wants to view the approve details in the Transfer Requisition, then user can click the approve Icon, the user can double click the Reference No. Field and select a predefined Entry and then the details of that particular one will be appeared.

![Image of approve confirmation dialog]

After the Entry Details appeared, the user can click save an option box will appear and user can select Yes/No. Like above Image, if user select Yes option and then that particular Entry will be approved, if No then the entry will not go further.

**Action Flow**

Approve Icon ➔ Reference No. ➔ Details Appeared ➔ Click save Icon ➔
Select Yes ➔ Approved

**Transfer Note**

Transfer Note is used as a request for transferring material within the inventory locations. Any authorized user can enter the transfer request on behalf of the inventory location.
Upon Clicking **New** the user will be able to Insert a Manual No., then in the Transfer Requisition Details, user will be able to select a Transfer Requisition, and then other fields will be auto generated. If User wants he/she can comment Remarks. Then enter the quantity of the particular product. Then the user may click Save.

**Action Flow**

New ➔ Manual No ➔ Transfer Requisition ➔ Remarks ➔ Quantity ➔

Click Save Icon
When it comes to **Editing** an entry in Transfer Note, the user will be able to edit an Entry. User must select **Edit** and then user can Select a predefined **Reference No.** and then edit the , **Manual No** and **Remarks** and can edit the **product quantity** as above Image. User can only Edit or make changes to the above mentioned Fields and then user must click **Save**.

**Action Flow:**

Edit Icon ➔ Reference No. ➔ Edit the Needed Fields ➔ Click Save Icon

In the case of **Deleting** an entry the user must select **Delete**, then user will be able to select a Predefined **Reference No.** and upon which the user will be prompted to a popup message that to enter a Reason to Delete the Entry as above Image. After Entering a Reason, User will be able to Click OK and that particular Entry will be Deleted. When User didn't enter any Reason then below popup Message will appear and user won't be able to delete the Entry.

**Action Flow**

Delete Icon ➔ Reference No. ➔ Select Yes ➔ Record Deleted.
**Transfer Confirmation**

In Transfer Confirmation, any authorized user having the necessary privileges can select the inventory location from which the items should be transferred. He can modify the item details, quantity, approve or reject the Transfer Note.

Upon Clicking **Approve**, the user will be able to Insert a Reference No., and then other fields will be auto generated. If User wants, he/she can comment a Remarks. User can edit the quantity of that particular product. Then the user may click Save.
After the Entry Details appeared, the user can click save an option box will appear and user can select Yes/No. Like above Image, if user select Yes option and then that particular Entry will be approved, if No then the entry will not go further.

**Action Flow**

Approve Icon → Reference No. → Details Appeared → Click save Icon → Select Yes → Approved

**Issue**

**Issue Requisition**

Issue stored products from stock only with an authorized issue requisition form.

Upon Clicking New the user will be able to Insert a Manual Ref No., then in the Issue Details, user must select an Issue Type, Material Issue Category. Then in the Cost Centre/Location Details, User must select Location Code and a Cost Centre. Product Code, Quantity must insert in the grid.

Select an Issue Type, Material Issue Category. Then in the Cost Centre/Location Details, User must select Location Code and a Cost Centre. Product Code, Quantity must insert in the grid.
Action Flow

New ➔ Manual Ref No ➔ Issue Type ➔ Material Issue Category ➔ Location Code ➔ Cost Centre ➔ Remarks ➔ Product Code ➔ Quantity ➔ Click Save Icon

When it comes to Editing an entry in Issue Requisition, the user will be able to edit an Entry. User must select Edit and then user can Select a predefined Reference No. and then edit the, Manual No Material Issue Category, Location Code, Cost Centre and Remarks and can edit the product quantity as above Image. User can only Edit or make changes to the above mentioned Fields and then user must click Save.

Action Flow:

Edit Icon ➔ Reference No. ➔ Edit the Needed Fields ➔ Click Save Icon

In the case of Deleting an entry the user must select Delete, then user will be able to select a Predefined Reference No. and upon which the user will be prompted to a popup message that to enter a Reason to Delete the Entry as above Image. After Entering a Reason, User will be
able to Click OK and that particular Entry will be Deleted. When User didn't enter any Reason then below popup Message will appear and user won't be able to delete the Entry.

**Action Flow**

Delete Icon ➔ Reference No. ➔ Select Yes ➔ Record Deleted.

If the user wants to view the approve details in the Issue Requisition, then user can click the approve Icon, the user can double click the **Reference No.** Field and select a predefined Entry and then the details of that particular one will be appeared.

![popup Message](image)

After the Entry Details appeared, the user can click save an option box will appear and user can select **Yes/No.** Like above Image, if user select **Yes** option and then that particular Entry will be approved, if No then the entry will not go further.

**Action Flow**

Approve Icon ➔ Reference No. ➔ Details Appeared ➔ Click save Icon ➔ Select Yes ➔ Approved

**Issue Note**

Issue Note is used as a request for issue material within the inventory locations. Any authorized user can enter the issue request on behalf of the inventory location.
Upon clicking **New** the user will be able to Insert a Manual No., then in the Issue Details, user must select an Issue Type, Material Issue Category and Issue Requisition then in the Cost Centre/Location Details Section, user must select a Location Code and Cost Centre and then user will be able to add Remarks.

**Action Flow**

New → Manual No → Issue Type → Material Issue Category → Issue Requisition → Location Code → Cost Centre → Remarks → Product Quantity → Click Save Icon
In the case of **Deleting** an entry the user must select **Delete**, then user will be able to select a Predefined Reference No. and upon which the user will be prompted to a popup message that to enter a Reason to Delete the Entry as **above Image**. After Entering a Reason, User will be able to Click OK and that particular Entry will be Deleted. When User didn't enter any Reason then below popup Message will appear and user won't be able to delete the Entry.

**Action Flow**

Delete Icon ➔ Reference No. ➔ Select Yes ➔ Record Deleted.

**Issue Return With Issue**
This has the ability to issue stocks from a selected location and it Increase the stock balance of a particular location.

Select a Issue Type, Material Issue Category and then in the Cost Center/Location Details Section, user must select a Location Code and a Cost Centre.

In the grid, user can select a Issue No and Product Code by double Clicking the fields and can edit Quantity of that particular product.
Upon Clicking **New** the user will be able to Insert a Manual No., then in the Issue Details, user must select a Issue Type, Material Issue Category and then in the Cost Centre/Location Details Section, user must select a Location Code and a Cost Centre and then user will be able to add Remarks. Then in the below grid user can select a Issue No and Product Code by double Clicking the fields and can edit Quantity of that particular product. Then the user may click Save

**Action Flow**

New → Manual No → Issue Type → Material Issue Category → Location Code → Cost Centre → Remarks → Issue No → Product Code → Quantity → Click Save Icon

**Issue Return Without Issue**

This has the ability to insert a Location Code and cost centre that will be filtering the product in the grid.

Upon Clicking **New** the user will be able to Insert a Manual Ref No., then in the Cost Centre/Location Details, user must select a Location Code and a Cost Centre and then user...
will be able to add Remarks. Then in the below grid user can select a Product Code by double clicking the field and can edit Quantity and the Cost Price of that particular product. Then the user may click Save

**Action Flow**

New ➔ Manual Ref No ➔ Location Code ➔ Cost Centre ➔ Remarks ➔ Product Code ➔ Quantity ➔ Cost Price ➔ Click Save Icon

In the case of **Deleting** an entry the user must select **Delete**, then user will be able to select a Predefined **Reference No.** and upon which the user will be prompted to a popup message that to enter a Reason to Delete the Entry as **above Image**. After Entering a Reason, User will be able to Click OK and that particular Entry will be Deleted. When User didn't enter any Reason then below popup Message will appear and user won't be able to delete the Entry.

**Action Flow**

Delete Icon ➔ Reference No. ➔ Select Yes ➔ Record Deleted.

**Adjustments**

**Adjustment - Addition**

Adjustment Addition has the ability to enter stock adjustment for a particular location.

Increase the stock balance of a particular location
Upon Clicking **New** the user will be able to Insert a Manual No., then in the Cost Centre/Location Details, After inserting these Details, in the above grid field, user can double click and select Product Code and Products will be displayed in the below grid as above Image. Then enter the quantity and the Price of that particular product.

- When user Double Click the quantity field a popup box will appear. When user select a product that is as Serial, the below Image pop up box will appear, after filling the fields, user may click Save.
On the above popup box user **must enter** values for all the fields as Serial No, Description, Cost Price. When user select a product that is as Batch, the below Image pop up box will appear.
On the above popup box user **must enter** values for all the fields as Batch No, Quantity, Cost Price, Manufacture Date and Expire Date. When user insert a greater quantity and then popup box will appear.

**Action Flow**

New ➔ Manual No ➔ Cost Centre ➔ Location Code ➔ Reason ➔ Remarks ➔
Product Code ➔ Click Save Icon

When it comes to **Editing** an entry in Adjustment- Adding, the user will be able to edit an Entry. User must select **Edit** and then user can Select a predefined **Reference No.** and then edit the , **Manual No., Cost Centre, Location Code, Reason, Remarks** as above Image. User can only Edit or make changes to the above mentioned Fields and then user must click **Save**.

**Action Flow:**

Edit Icon ➔ Reference No. ➔ Edit the Needed Fields ➔ Click Save Icon
In the case of **Deleting** an entry the user must select **Delete**, then user will be able to select a Predefined **Reference No.** and upon which the user will be prompted to a popup message that to enter a Reason to Delete the Entry as **above Image**. After Entering a Reason, User will be able to Click OK and that particular Entry will be Deleted. When User didn't enter any Reason then popup Message will appear and user won't be able to delete the Entry.

**Action Flow**

Delete Icon ➔ Reference No. ➔ Select Yes ➔ Record Deleted.

If the user wants to view the approve details in the Adjustment- Addition, then user can click the approve Icon, the user can double click the **Reference No.** Field and select a predefined Entry and then the details of that particular one will be appeared.

![Image of approval prompt](image)

After the Entry Details appeared, the user can click save an option box will appear and user can select **Yes/No**. Like above Image, if user select **Yes** option and then that particular Entry will be approved, if No then the entry will not go further.

**Action Flow**

Approve Icon ➔ Reference No. ➔ Details Appeared ➔ Click save Icon ➔ Select Yes ➔ Approved

**Adjustment- Deduction**

Adjustment Deduction has the ability to enter stock adjustment for a particular location. This Decreases the stock balance of a particular location
Upon Clicking **New** the user will be able to Insert a Manual No., then in the Cost Centre/Location Details, user will be able to select a Cost Centre and Location Code, then user can select a reason and insert a Remarks. Location Code, Cost Centre, Remarks and After inserting these Details, in the above grid field, user can double click and select Product Code and Products will be displayed in the below grid as above Image. Finally the user may click Save.

**Action Flow**

New ➔ Manual No ➔ Location Code ➔ Cost Centre ➔ Reason ➔ Remarks ➔ Product Code ➔ Click Save Icon
When it comes to **Editing** an entry in Adjustment- Deduction, the user will be able to edit an Entry. User must select **Edit** and then user can select a predefined **Reference No.** and then edit the , **Manual No., Cost Centre, Location Code, Reason, Remarks** as **above Image.**

User can only Edit or make changes to the above mentioned Fields and then user must click **Save.**

**Action Flow:**

Edit Icon ➔ Reference No. ➔ Edit the Needed Fields ➔ Click Save Icon

In the case of **Deleting** an entry the user must select **Delete,** then user will be able to select a Predefined **Reference No.** and upon which the user will be prompted to a popup message that to enter a Reason to Delete the Entry as **above Image.** After Entering a Reason, User will be able to Click OK and that particular Entry will be Deleted. When User didn't enter any Reason then below popup Message will appear and user won’t be able to delete the Entry.

**Action Flow**

Delete Icon ➔ Reference No. ➔ Select Yes ➔ Record Deleted.
When the user wants to **View** an entry that is already inserted, then user can click the View icon, by clicking the view in this Good Received Note an option box will appear that is to click Yes/No. If the user click yes then the user will be able to view approved Entries. If the user clicks No then Unapproved Entries can be viewed by the user. As Below Image,

![Image](image_url)

After Selecting an option then insert the Reference No. of the entry that user wants to view and then the entry details will be displayed. User can only **View** the entries as below

If the user wants to view the approve details in the Adjustment- Addition, then user can click the approve Icon, the user can double click the **Reference No.** Field and select a predefined Entry and then the details of that particular one will be appeared.

![Image](image_url)

After the Entry Details appeared, the user can click save an option box will appear and user can select **Yes/No**. Like above Image, if user select **Yes** option and then that particular Entry will be approved, if No then the entry will not go further.

**Action Flow**

Approve Icon ➔ Reference No. ➔ Details Appeared ➔ Click save Icon ➔ Select Yes ➔ Approved
Stock Module Main Panel: Sub Section 3
(Reports - Stock)
Purchasing

Purchase Requisition Details

Upon clicking the Purchase Requisition Report, the User will be prompted to choose a Date from and Date to (Date Range), then the user is able to filter the Report based on the below list.

- Product Group Code
- Product Type Code
- Product Code

After selecting the required area of the Purchase Requisition Report, then the user will be able to select the below two options

- Unapproved
- Approved

If User select the Approved Option, then User will be able to select another three option as below,

- Pending
- Completed
- All
After Selecting the above options of the Purchase Requisition Report then the user will be able to select an option between the below two options.

- Details
- Summary - Item Wise

These options will get the Purchase Requisition Report of the selected option then the user will be able to get the filtered report of the Purchase Requisition Report, user may Click Print to View/Print.

**Action Flow:**

Purchase Requisition Report → Date from → Date to → Select the required area → Select the Options → Click the Print Icon

**Pending PO Listing**

Upon clicking the Pending PO Listing, the User will be prompted to choose a **Date from** and **Date to** (Date Range), then the user is able to filter the Report based on the below list.

- Product Group Code
- Product Type Code
- Product Code
- Supplier Code
- Supplier
After selecting the required area of the **Pending PO Listing**, then the user will be able to select the below two options:

- Unapproved
- Approved

If User select the Approved Option, then User will be able to select another three option as below,

- Pending
- Completed
- All

After Selecting the above options of the Pending PO Listing then the user will be able to select an option between the below two options.

- Details
- Summary - Item Wise

These options will get the Pending PO Listing of the selected option then the user will be able to get the filtered report of the Pending PO Listing, user may Click Print to **View/Print**

**Action Flow:**

Pending PO Listing ➔ Date from ➔ Date to ➔ Select the required area ➔
Select the Options ➔ Click the Print Icon
Sales

Invoice Profitability

Upon clicking the **Invoice Profitability**, then the user will be prompted to choose Date from and Date to (**Date Range**), then the user will be able to filter the report based on the below list.

- Location Code
- Cost Centre
- Customer Group
- Area
- Rank
- Customer
- Sales Rep
- Product Group Code
- Product Type Code
- Product Code

After selecting the required area, user will have the option to tick 'Under Cost Sales Only' the user can get a filtered report, user may click Print to **View/Print**.
Action Flow

Invoice Profitability ➔ Date from ➔ Date to ➔ Select the Required area ➔
Tick/Undo Under Cost Sales Only ➔ Click the Print Icon

Sales

Upon clicking the Sales, then the user will be prompted to choose Date from and Date to (Date Range), then the user will be able to filter the report based on the below list.

- Location Code
- Sales Rep
- Customer Group
- Customer
- Area
- Product Group Code
- Product Type Code
- Product Code
- Cost Centre
- Currency Code
After selecting the required area of the Sales, then the user will be able to select the below three options

- Cash
- Credit
- Cash/Credit

Then User will be able to select another two option as below,

- Details
- Summary

After Selecting an option as above, then the user will be able to select an option between the below three options.

- Sales
- Returns
- All

These options will get the Sales of the selected option then the user will be able to get the filtered report of the Sales, user may Click Print to View/Print

**Action Flow**

Sales ➔ Date from ➔ Date to ➔ Select the Required area ➔ Select Options ➔

Click the Print Icon
Upon clicking the **Dispatch Detail**, then the user will be prompted to choose Date from and Date to (**Date Range**), then the user will be able to filter the report based on the below list.

- Location Code
- Customer Group
- Customer
- Area
- Product Group Code
- Product Type Code
- Product Code

After selecting the required area of the **Dispatch Detail**, then the user will be able to select the below two options

- Dispatch Notes
- Pending Dispatch Notes
Action Flow

Sales ➔ Date from ➔ Date to ➔ Select the Required area ➔ Select an Option ➔
Click the Print Icon

**Price List**

Upon clicking the **Price List**, then the user will be able to filter the report based on the below list.

- Product Group Code
- Product Type Code
- Product Code
- Price Level Code

After selecting the required area, the user can get a filtered report, user may click Print to **View/Print**.

**Action Flow:**

Price List ➔ Select the required area ➔ Click the Print Icon
Stocks

Bin Card

Upon Clicking the **Bin Card**, the user will be prompted to choose a Date from and date to (Date Range), then the user will be able to filter the report based on the below list.

- Location Code
- Product Group Code
- Product Type Code
- Product Code

After selecting the required area, the user can get a filtered report, user may click Print to View/Print.

**Action Flow**

Bin Card  ➔ Date from  ➔ Date to  ➔ Select the Required area  ➔ Click the Print Icon
Location Stock Details

Upon Clicking the Location Stock Details, the user will be prompted to choose a Date from and date to (Date Range), then the user will be able to filter the report based on the below list.

- Location Code
- Product Group Code
- Product Type Code
- Product Code

After selecting the required area, the user can get a filtered report, user may click Print to View/Print.

Action Flow

Location Stock Details ➔ Date from ➔ Date to ➔ Select the Required area ➔
Click the Print Icon

Stock Balance
Upon clicking the **Stock Balance**, then the user will be prompted to choose **As At date**, then the user will be able to filter the report based on the below list.

- Location Code
- Product Group Code
- Product Type Code
- Product Code

After selecting the required area of the Stock Balance Report, then the user will be able to select an option between the below two options.

- Detail
- Summary

These options will get the Stock Balance Report of the selected option then the user will be able to get the filtered report of the Stock Balance Report, user may Click Print to **View/Print**. By ticking the With Serial With Batch Box, User will be able to view the Serial and Batch product's cost prices in the Report by clicking the Value Column as below,

### Datamation Pvt Ltd

No.15, Shambrey Gardens, Colombo 03

**Stock Balance - Detail**

<table>
<thead>
<tr>
<th>Stock Received No</th>
<th>Reference No</th>
<th>Serial No</th>
<th>Cost Price</th>
<th>Unit Quantity</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ALU - Aluthgama</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>05SVY14 - CFL 05V 3P WL E14</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>AA/1607/0000003</td>
<td>AA/1607/0000003</td>
<td>000000000000000005</td>
<td>425.00</td>
<td>1.00</td>
<td>425.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>M000000000000000001</td>
<td>425.00</td>
<td>1.00</td>
<td>425.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>M000000000000000002</td>
<td>425.00</td>
<td>1.00</td>
<td>425.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>M000000000000000003</td>
<td>425.00</td>
<td>1.00</td>
<td>425.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>M000000000000000004</td>
<td>425.00</td>
<td>1.00</td>
<td>425.00</td>
</tr>
<tr>
<td><strong>Total</strong></td>
<td></td>
<td></td>
<td></td>
<td>5.00</td>
<td>2,125.00</td>
</tr>
</tbody>
</table>

Software By: Datamation Systems (Pvt) Ltd. Tel: +94(0)11 2501202
Action Flow:

Stock Balance Report ➔ As At Date ➔ Select the required area ➔ Select an Option ➔ Tick the Option ➔ Click the Print Icon

Age Analysis

Upon clicking the Age Analysis, then the user will be prompted to choose As At date, then the user will be able to filter the report based on the below list.

- Product Group Code
- Product Type Code
- Product Code

After selecting the required area of the Age Analysis, then the user will be able to select the below two options

  - Details
  - Summary

After Selecting an above option of the Age Analysis then the user will be able to select an option between the below three options.

  - Quantity
  - Value
  - Both

These options will get the Age Analysis of the selected option then the user will be able to get the filtered report of the Age Analysis, user may Click Print to View/Print. By ticking the
With Serial With Batch Box, User will be able to view the Serial and Batch product's Cost Prices in the Report by Clicking the Value Column as below,

**Action Flow:**

Age Analysis ➔ As At Date ➔ Select the required area ➔ Select an Option ➔ Click the Print Icon

**Re-Order**

Upon clicking the **Re-Order**, then the user will be prompted to choose **As At date**, then the user will be able to filter the report based on the below list.

- Product Group Code
- Product Type Code
- Product Code

After selecting the required area, the user can get a filtered report, user may click Print to **View/Print**.

**Action Flow:**

Re-Order ➔ As At Date ➔ Select the required area ➔ Click the Print Icon
Stock Movement

Upon clicking the Stock Movement, then the user will be prompted to choose Date from and Date to (Date Range), then the user will be able to filter the report based on the below list.

- Product Group Code
- Product Type Code
- Product Code

After selecting the required area of the Stock Movement, then the user will be able to select the below two options

- Detail
- Summary

When User Selects Detail Option of the Stock Movement then the user will be able to select an option between the below three options.

- Quantity
- Value
- Both

These options will get the Stock Movement of the selected option then the user will be able to get the filtered report of the Stock Movement, user may Click Print to View/Print
Action Flow

Stock Movement → Date from → Date to → Select the Required area → Select options → Click the Print Icon

Audit Trails

Upon clicking the Audit Trails, then the user will be prompted to choose Date from and Date to (Date Range of Transaction & System), User can Select a Report by Clicking the Report Name, then the user will be able to filter the report based on the below list.

- User
- Reference No
- Product Group Code
- Product Type Code
- Product Code
- Currency Code

After selecting the required area of the Report, then the user will be able to get the filtered report of the Audit Trails, user may Click Print to View/Print

Action Flow

Audit Trails → Date from → Date to → Select the Required area → Click the Print Icon
System Main Panel: Administration (Sub Section 1: Master Files)
**Tax Codes**

Normally Active Tax Codes will be needed in the Tax Combination Master File. By giving Receivable A/C, Payable A/C, Name of the Tax and Tax Percentage user can continue the process.

Upon clicking **New**, the User will be prompted to insert a **Tax Code** upon which the User will be prompted to Assign a **Tax Name** for the Tax M/F, and Select a **Receivable A/C**, **Payable A/C**, **Suspended A/C**, **Active** and **Insert Tax Percentage**. upon filling the fields the User may click **Save** to insert the entry into the system.

**Action Flow:**

New ➔ Tax Code ➔ Tax Name ➔ Receivable A/C ➔ Payable A/C ➔ Suspended A/C ➔ Tax Percentage ➔ Active Status ➔ Click Save Icon
When it comes to **Editing** an entry in Tax M/F, the user will be able to edit an Entry. User must select **Edit** and then user can edit the **Tax Name, Receivable A/C, Payable A/C, Suspended A/C, Active** and **Tax Percentage** as above Image. User can only Edit or make changes to the above mentioned Fields and then user must click **Save**.

**Action Flow:**

Edit Icon ➔ Edit the Mentioned Fields ➔ Click Save Icon

In the case of **Deleting** an entry the user must select **Delete**, upon which the user will be prompted to select **Yes** or **No**. If the user wanted to delete the Entry, then select Yes, and the Entry will be deleted as above Image. If the user already Used in other transactions and if it is in already in Process, then the user cannot delete the entry.

**Action Flow:**

Click Delete Icon ➔ Select Yes ➔ Deleted

**Tax Combination**

In this Particular master file, User can insert many combination in a particular Tax Combination Code. The Codes for the combinations will be taken from the previous master file that is Tax Codes.
Upon Clicking **New** the user will be able to Insert a Tax Combination Code then Tax Combination. User will be able to double click and select a Tax Code in the grid and the Description.

- In the above grid, User can insert Tax Rate, Tax Sequence and Remarks. Then User can Tick the Active Box. Upon filling these fields, the user may click Save.
- User cannot **Duplicate** the Tax Sequence and Tax Code in the grid, the below popup messages will appear when it is duplicated.
Action Flow:

New → Tax Combination Code → Tax Combination Name → Tax Code → Description → Tax Rate → Tax Sequence → Remarks → Click the Print Icon

When it comes to Editing an entry in Tax Combination, the user will be able to edit an Entry. User must select Edit and then user can edit the, Tax Combination Name and can edit the grid as above Image. User can only Edit or make changes to the above mentioned Fields and then user must click Save.

Action Flow:

Edit Icon → Edit the Tax Combination Name/Grid → Click Save Icon

In the case of Deleting an entry the user must select Delete, upon which the user will be prompted to select Yes or No. If the user wanted to delete the Entry, then select Yes, and the Entry will be deleted as above Image. If the user already Used in other transactions and if it is in already in Process, then the user cannot delete the entry. As below Image an popup message will be appear, Same goes to the other Master Files.

Action Flow:

Click Delete Icon → Select Yes → Deleted
Currency

Generally in this particular master file, user will be able to define the different kinds of currency. It maintains the records of the Daily Currency

Upon clicking **New**, the User will be prompted to insert a **Currency Code** upon which the User will be prompted to Assign a **Description** for the Currency, and insert **Rate from and Rate To** (Currency Exchange Rate) upon filling the fields the User may click **Save** to insert the entry into the system.

**Action Flow:**

New ➔ Currency Code ➔ Description ➔ Rate from ➔ Rate to ➔ Click Save Icon
When it comes to **Editing** an entry in Currency, the user will be able to edit an Entry. User must select **Edit** and then user can edit the, **Description and Rate Range** as above Image. User can only Edit or make changes to the above mentioned Fields and then user must click **Save**.

**Action Flow:**

Edit Icon  ➔  Edit Description/Rate Range  ➔  Click Save Icon

In the case of **Deleting** an entry the user must select **Delete**, upon which the user will be prompted to select **Yes** or **No**. If the user wanted to **delete** the Entry, then select Yes, and the Entry will be deleted as **above Image**. If the user already Used in other transactions and if it is in already in Process, then the user cannot delete the entry.

**Action Flow:**

Click Delete Icon  ➔  Select Yes  ➔  Deleted

**Daily Currency**

User will be able to update the currency buying rate, and insert the updated exchange date.
Upon clicking **New**, the User will be prompted to select a **Currency Code** upon which the User will be prompted to Assign a **Buying Rate** for the Currency, and insert a **Exchange Date** upon filling the fields the User may click **Save** to insert the entry into the system.

**Action Flow:**

New → Currency Code → Buying Rate → Exchange Date → Click Save Icon

When it comes to **Editing** an entry in Daily Currency, the user will be able to edit an Entry. User must select **Edit** and then user can edit the, **Currency Code, Exchange Date and Buying Rate** as above Image. User can only Edit or make changes to the above mentioned Fields and then user must click **Save**.
Action Flow:

Edit Icon ➔ Edit Currency Code/Exchange Date/Buying Rate ➔ Click Save Icon

In the case of Deleting an entry the user must select Delete, upon which the user will be prompted to select Yes or No. If the user wanted to delete the Entry, then select Yes, and the Entry will be deleted as above Image. If the user already Used in other transactions and if it is in already in Process, then the user cannot delete the entry.

Action Flow:

Click Delete Icon ➔ Select Yes ➔ Deleted

**Price Level**

There are different tiers of price levels when selling items, so the organization can set up pricing levels that allows to select various price points for inventory items
Upon clicking **New**, the User will be prompted to insert a **Price Level Code** upon which the User will be prompted to Assign a **Price Level Name** and Select a **Currency Code**. Upon filling the fields the User may click **Save** to insert the entry into the system.

**Action Flow:**

New ➔ Price Level Code ➔ Price Level Name ➔ Currency Code ➔ Click Save Icon

When it comes to **Editing** an entry in Price Level, the user will be able to edit an Entry. User must select **Edit** and then user can edit the, **Price Level Name** and **Currency Code** as above Image. User can only Edit or make changes to the above mentioned Fields and then user must click **Save**.
Action Flow:

Edit Icon → Edit the Price Level Name/Currency Code → Click Save Icon

In the case of Deleting an entry the user must select Delete, upon which the user will be prompted to select Yes or No. If the user wanted to delete the Entry, then select Yes, and the Entry will be deleted as above Image. If the user already Used in other transactions and if it is in already in Process, then the user cannot delete the entry.

Action Flow:

Click Delete Icon → Select Yes → Deleted

Card Type

Card Type determines the different types of cards, user must enter the card type code and card type name and user should keep the Status as Active.
Upon clicking **New**, the User will be prompted to insert a **Card Type Code** upon which the User will be prompted to **Assign a Card Type Name** and **Select a Active**. upon filling the fields the User may click **Save** to insert the entry into the system.

**Action Flow:**

New ➔ Card Type Code ➔ Card Type Name ➔ Click Save Icon

When it comes to **Editing** an entry in Card Type, the user will be able to edit an Entry. User must select **Edit** and then user can edit the, **Card Type Name, Active** as above Image. User can only **Edit** or make changes to the above mentioned Field and then user must click **Save**.
Action Flow:

Edit Icon  ➤ Edit the Card Type Name  ➤ Click Save Icon

In the case of **Deleting** an entry the user must select **Delete**, upon which the user will be prompted to select **Yes** or **No**. If the user wanted to **delete** the Entry, then select Yes, and the Entry will be deleted as **above Image**. If the user already Used in other transactions and if it is in already in Process, then the user cannot delete the entry.

**Action Flow:**

Click Delete Icon ➤ Select Yes ➤ Deleted

**User Wise Cost Centre Allocation**
Generally User Wise Cost Centre Allocation maintains the records of Cost Centre. User must select User ID and Default Cost Centre.
Upon clicking **New**, the user will be prompted to **Select** a predefined User ID upon which the user will be able to Select a **Cost Centre**.

- Upon filling the fields the User may Select or unselect the Cost Centre by a tick. Then User may click **Save** to insert the entry into the system.

**Action Flow:**

New ➔ User ID ➔ Select the Cost Centre ➔ Click Save Icon

User ID and Cost Centre are Mandatory Fields, User must fill the fields.
When it comes to **Editing** an entry in User Wise Cost Centre Allocation, the user will be able to edit an Entry. User must select **Edit** and then user can select/deselect the Cost Centre as above Image.

**Action Flow:**

Edit Icon → Select/Deselect → Click Save Icon

![Popup Message](image)

In the case of **Deleting** an entry the user must select **Delete**, then user will be able to select a Predefined **User ID** and upon which the user will be prompted to a popup message that to enter a Reason to Delete the Entry as **above Image**. After Entering a Reason, User will be able to Click OK and that particular Entry will be Deleted. When User didn't enter any Reason then popup Message will appear and user won't be able to delete the Entry.

**Action Flow**

Delete Icon → User ID → Select Yes → Record Deleted

**User Wise Location Allocation**
Generally User Wise Location Allocation maintains the records of Locations. User must select User ID and Default Location.
Upon clicking **New**, the User will be prompted to Select a predefined User ID upon which the User will be prompted to Select a **Location**.

- upon filling the fields the User may Select or Deselect the Cost Centre by a tick. Then User may click **Save** to insert the entry into the system.

**Action Flow:**

New → User ID → Select Default Location → Click Save Icon
When it comes to **Editing** an entry in User Wise Location Allocation, the user will be able to edit an Entry. User must select **Edit** and then user can Select/Deselect the Location as above Image.

**Action Flow:**

Edit Icon  →  Select/Deselect  →  Click Save Icon

In the case of **Deleting** an entry the user must select **Delete**, then user will be able to select a Predefined **User ID** and upon which the user will be prompted to a popup message that to enter a Reason to Delete the Entry as **above Image**. After Entering a Reason, User will be able to Click OK and that particular Entry will be Deleted. When User didn't enter any Reason then popup Message will appear and user won't be able to delete the Entry.

**Action Flow**

Delete Icon → User ID → Select Yes → Record Deleted
System Main Panel: Administration (Sub Section 2: System Maintenance)
Upon clicking **Company Profile**, the User will be prompted to insert a To Date of Debtor/Creditor Age and Stock Age. Upon which the User will be able to change the days.

- Then upon filling the fields the User may insert Accounting Period 'To' and user will be able to Data Entry Period From-To. Then User may click **Save** to insert the entry into the system.

**Action Flow:**

Company Profile  ➔  Debtor/Creditor Age  ➔  Stock Age  ➔  Accounting Period 'To' ➔
Data Entry Period From  ➔ Data Entry Period To  ➔ Click Save Icon

**Backup Data Files**

Backup Data Files are the result of copying or archiving data files for the purpose of being able to restore them in case of data loss.
Upon clicking **Backup Data Files**, the User will be able to insert a Backup Path, then the user will be able to Save the Path.

**Action Flow:**

Backup Data Files → Backup Path → Click Save Icon

**Change Password**

Change Password is an operation that allows an administrator to set a new user password, This allows user to change the Password.
Upon clicking Change Password, the user will be able to insert a Username, Current Password, New Password and Confirm Password then the user will be able to Save the New Password.

**Action Flow:**

Change Password → Username → Current Password → New Password → Confirm Password → Click Save Icon
Shipment Costing Main Panel: Sub Section 1
(Master Files)
**HS Code**
The HS code reduces the costs related to international trade as there is no translator required for people to read and understand this code. HS Code is Common Standard for describing the type of an Item/Product. The code helps to standardize and identify Item load.

Upon clicking **New** the system user will be prompted to insert a **HS Code** upon which the System User must Assign HS Code Name. User can insert Percentage/Value of Tax Variable.

- The above fields are mandatory and user must fill these fields. Upon filling these fields the System User may click **Save** to insert the entry into the system.

**Action Flow:**

New  →  HS Code  →  HS Code Name  →  Percentage/Value  →  Click Save Icon
When it comes to **Editing** an entry in HS Code, the user will be able to edit an Entry. User must select **Edit** and then user can edit the **HS Code Name and Percentage/Value as above Image**. User can only Edit or make changes to the mentioned fields and then user must click **Save**.

**Action Flow:**

Edit Icon ➔ Edit the Needed Fields ➔ Click save Icon

In the case of **Deleting** an entry the user must select **Delete**, upon which the user will be prompted to select **Yes** or **No**. If the user wanted to delete the Entry, then select Yes, and the Entry will be deleted as **above Image**. If the user already Used in other transactions and if it is already in Process, then the user cannot delete the entry.

**Action Flow:**

Click Delete Icon ➔ Select Yes ➔ Deleted

**Charge Category**

Charge Category is used to Categorize the Charges, This is for the Reporting Purpose.
Upon clicking **New** the system user will be prompted to insert a **Unique Charge Category Code** upon which the System User must Assign a **Charge Category Name**.

- The above fields are mandatory and user must fill these fields. Upon filling these fields the System User may click **Save** to insert the entry into the system.

**Action Flow:**

New → Charge Category Code → Charge Category Name → Click Save Icon

When it comes to **Editing** an entry in Charge Category, the user will be able to edit an Entry. User must select **Edit** and then user can edit the **Charge Category Name** as above Image.
User can only Edit or make changes to the above mentioned Field and then user must click Save.

**Action Flow:**

Edit Icon ➔ Edit the Charge Category Name ➔ Click Save Icon

In the case of **Deleting** an entry the user must select **Delete**, upon which the user will be prompted to select **Yes** or **No**. If the user wanted to **delete** the Entry, then select Yes, and the Entry will be deleted as **above Image**. If the user already Used in other transactions and if it is in already in Process, then the user cannot delete the entry.

**Action Flow:**

Click Delete Icon ➔ Select Yes ➔ Deleted

**Charge**

These are import related charges, that has been categorized. This can be Default.
Upon clicking New the system user will be prompted to insert a Unique Charge Code then Insert a Charge Description and select a Charge Category Code. These fields are Mandatory, user must fill these fields. Upon filling these fields the System User can select the status as Active by ticking the box. Then User may click Save to insert the entry into the system.

**Action Flow:**

New → Charge Code → Charge Description → Charge Category Code → Status → Click Save Icon
When it comes to **Editing** an entry in Charge, the user will be able to edit an Entry. User must select **Edit** and then user can edit the, **Charge Description and Status** as above Image. User can only Edit or make changes to the above mentioned Field and then user must click **Save**.

**Action Flow:**

Edit Icon ➔ Edit the Charge Description ➔ Click Save Icon

---

In the case of **Deleting** an entry the user must select **Delete**, upon which the user will be prompted to select **Yes** or **No**. If the user wanted to **delete** the Entry, then select Yes, and the Entry will be deleted as **above Image**. If the user already Used in other transactions and if it is in already in Process, then the user cannot delete the entry.

**Action Flow:**

Click Delete Icon ➔ Select Yes ➔ Deleted
Shipment Costing Main Panel: Sub Section 2
(Transaction)
LC Opening Entry

LC well known as Letters of Credits are used for international transactions and help guarantee that payments will be made. LC is an Agreement that issued by bank, the bank guarantees the payment behalf of the buyer. This is referred to as a documentary credit.

Upon clicking **New** the system user will be prompted to select a **Currency Code** upon which the System User must Assign an Exchange Rate, Expire Date, LC Number, LC Amount, then Entry Type, Supplier and Bank Account. These Fields are Mandatory, User must fill the fields.

Upon Selecting an option, user can select a predefined Supplier and Bank Account.
- The above mentioned fields are Mandatory, user must fill the fields. Upon filling the mentioned fields the System User may click Save to insert the entry into the system.

**Action Flow:**

New ➔ Currency Code ➔ Exchange Rate ➔ Expire Date ➔ LC Number ➔ LC Amount ➔ Entry Type ➔ Supplier ➔ Bank A/C ➔ Click Save Icon

When it comes to Editing an entry in LC Opening Entry, the user will be able to edit an Entry. User must select Edit and then user must select a Reference No. Then User can edit the , **LC Details Section** as above Image. User can only Edit or make changes to the above mentioned sections Fields and then user must click Save.

![Popup Box]

When User select a Reference No, User cannot select if the LC has been allocated already in Commercial Invoice. A popup box will appear as above.

**Action Flow:**

Edit Icon ➔ Edit the mentioned Fields ➔ Click Save Icon

**Proforma Invoice**

Proforma invoice is a preliminary bill of sale sent to buyers in advance of a shipment or delivery of goods. This Particular Invoice will typically describe the purchased items and other important information such as the shipping weight and transport charges
Upon clicking **New** the system user will be prompted to insert a **Manual No.** upon which the System User must Assign/Select a **Purchase Order No., PO Type,**

- **Sea**
- **Air**

After Selecting a above PO Type, user must select Currency Code, Exchange Rate, Price Basis, Supplier, Cost Centre.

- The above mentioned fields are Mandatory, user must fill the fields and then user can insert Remarks.
- Upon filling these fields the user can insert quantity, Purchase Price and Discount in the below grid products.
- Quantity cannot exceed than the Purchase Order Quantity, below popup box will appear,
After inserting these values the User may click Save to insert the entry into the system.

**Action Flow:**

New → Manual No. → Purchase Order No. → PO Type → Currency Code Exchange→ Rate → Price Basis → Supplier → Cost Centre → In the Grid → Quantity → Purchase Price → Discount → Click Save Icon

When it comes to **Editing** an entry in Proforma Invoice, the user will be able to edit an Entry. User must select **Edit** and then user must select a Reference No. Then User can edit the Manual No, Exchange Rate, Price Basis, Remarks as above Image. User can Edit quantity, Purchase Price and Discount in the below grid products. User can only Edit or make changes to the above mentioned Fields and then user must click **Save**.
When User select a Reference No, User cannot select if the Proforma Invoice has been allocated already to a Commercial Invoice. A popup box will appear as above.

**Action Flow:**

```
Edit Icon → Edit the mentioned Fields → Click Save Icon
```

In the case of **Deleting** an entry the user must select **Delete**, then user will be able to select a Predefined **Reference No.** and upon which the user will be prompted to a popup message that to enter a Reason to Delete the Entry as **above Image**. After Entering a Reason, User will be able to Click OK and that particular Entry will be Deleted. When User didn't enter any Reason then popup Message will appear and user won't be able to delete the Entry.

**Action Flow**

```
Delete Icon → Reference No. → Reason → Select OK → Record Deleted.
```

**Commercial Invoice**

Commercial invoice is used to record 'accounts receivable' for the seller and accounts payable for the buyer. This provide a final statement reflecting what has occurred during the process of filling an order.
Upon clicking **New** the system user will be prompted to insert a **Manual No.** upon which the System User must Assign/Select a Proforma Invoice No, LC No,

- The above mentioned fields are Mandatory, user must fill the fields. User can insert Remarks. Insert quantity, Purchase Price and Discount in the below grid products.
- Quantity cannot exceed than the Purchase Order Quantity, a popup box will appear, upon filling fields the System User may click **Save** to insert the entry into the system.

**Action Flow:**

New ➔ Manual No. ➔ Proforma Invoice No ➔ Exchange Rate ➔ Remarks ➔
In the Grid ➔ Quantity ➔ Purchase Price ➔ Discount ➔ Click Save Icon
When it comes to **Editing** an entry in Commercial Invoice, the user will be able to edit an Entry. User must select **Edit** and then user must select a Reference No. Then User can edit the Manual No, Exchange Rate, LC No, Remarks as above Image. User can Edit quantity, Purchase Price and Discount in the below grid products. User can only Edit or make changes to the above mentioned Fields and then user must click **Save**.

When User select a Reference No, User cannot select if the Commercial Invoice has been allocated already to a Bill of Lading. A popup box will appear as above.

**Action Flow:**

Edit Icon ➔ Edit the mentioned Fields ➔ Click Save Icon
In the case of **Deleting** an entry the user must select **Delete**, then user will be able to select a Predefined **Reference No.** and upon which the user will be prompted to a popup message that to enter a Reason to Delete the Entry as **above Image**. After Entering a Reason, User will be able to Click OK and that particular Entry will be Deleted. When User didn't enter any Reason then popup Message will appear and user won't be able to delete the Entry.

**Action Flow**

Delete Icon ➔ Reference No. ➔ Reason ➔ Select OK ➔ Record Deleted.

**Bill of Lading**

The Bill of Lading is a transport kind of document that is enacting as a evidence of the contract that is carriage of goods. it is contains the carrier has received the load as per contract and the goods are received in good conditions.
Upon clicking New the system user will be prompted to select a Supplier upon which the System User must Assign/Select a Clearing Agent and insert a BL No, Vessel. In the Commercial Invoice Details User must select a Commercial Invoice No and insert Remarks.

- Upon filling these fields the System User may click Save to insert the entry into the system.

**Action Flow:**

New → Supplier → Clearing Agent → BL No → Vessel → Commercial Invoice No → Remarks → Click Save Icon
When it comes to **Editing** an entry in Bill of Lading, the user will be able to edit an Entry. User must select **Edit** and then user must select a Reference No. Then User can edit the Clearing Agent, BL Number, Vessel and Remarks as above Image. User can only Edit or make changes to the above mentioned Fields and then user must click **Save**.

**Action Flow:**

1. Edit Icon ➔ Edit the mentioned Fields ➔ Click Save Icon

In the case of **Deleting** an entry the user must select **Delete**, then user will be able to select a Predefined **Reference No.** and upon which the user will be prompted to a popup message that to enter a Reason to Delete the Entry as **above Image**. After Entering a Reason, User will be able to Click OK and that particular Entry will be Deleted. When User didn't enter any Reason then popup Message will appear and user won't be able to delete the Entry.

**Action Flow**

1. Delete Icon ➔ Reference No. ➔ Reason ➔ Select OK ➔ Record Deleted.

**Other Charges**

Other Charges includes Bank Charges, Clearing Expenses, Storage Charges of that particular Product.
Upon clicking **New** the system user will be prompted to Insert a **Manual No** upon which the System User must Select a Currency Code and then user can insert an Exchange Rate. User must select an option among:

- Actual
- Provision
- Prepaid

If user select Active option, User must select Supplier and Vat Supplier. If user select Prepaid option, User must select a Prepaid No., and then user can select a Tax Combination and insert Utilized Amount.

- Upon filling these fields User can select a Cost Centre and insert Remarks. In the Grid, User can select a Charge Code, Charge Amount and Tax Combination Code. A popup box will appear when Charge Amount is greater than Utilized Amount.
- The above mentioned fields are Mandatory, user must fill the fields. Then user may click Save.
Action Flow:

New → Manual No. → Currency Code → Exchange Rate → Charge Type (Active) →
BL No. → Bill No. → Tax Combination → Utilized Amount → Supplier →
Vat Supplier → Cost Centre → Remarks → In the Grid → Charge Code →
Charge Amount → Tax Combination Code → Click Save Icon

When it comes to Editing an entry in Other Charges, the user will be able to edit an Entry.
User must select Edit and then user must select a Reference No. Then User can edit the
Currency Code, BL Number, Exchange Rate, Bill Number, Tax Combination Supplier, Vat
Supplier, Cost Centre, Remarks and user can edit the grid Charge Code as above Image. User can only Edit or make changes to the above mentioned Fields and then user must click Save.

**Action Flow:**

Edit Icon → Edit the mentioned Fields → Click Save Icon

In the case of Deleting an entry the user must select Delete, then user will be able to select a Predefined Reference No. and upon which the user will be prompted to a popup message that to enter a Reason to Delete the Entry as above Image. After Entering a Reason, User will be able to Click OK and that particular Entry will be Deleted. When User didn't enter any Reason then popup Message will appear and user won't be able to delete the Entry.

**Action Flow**

Delete Icon → Reference No. → Reason → Select OK → Record Deleted

**Customs Duty Entry**

Customs Duty is a type of indirect tax levied on goods imported into the country as well as on goods exported from the country. Duties are based on the value of the goods, weight, quantity.
Upon clicking **New** the system user will be prompted to Insert a **Manual No** upon which the System User must Select a BL No and then user can insert an Exchange Rate. User must select a Duty among:

- Actual
- Prepaid

If it is Prepaid supplier field will be auto generated, if user select Active option, User must select Supplier. Upon filling these fields User can select a Cost Centre, these above mentioned fields are Mandatory, user must fill the fields and user can insert Remarks if he/she wants.

- In the Grid, when User click on Amount Field, user will get a popup up box to insert a Amount, all the fields are Mandatory in the grid. Then the user may click **Save**
When it comes to **Editing** an entry in Customs Duty, the user will be able to edit an Entry. User must select **Edit** and then user must select a Reference No. Then User can edit the Exchange Rate, Supplier, Cost Centre, Remarks and user can edit the grid Amount as above Image. User can only Edit or make changes to the above mentioned Fields and then user must click **Save**.
Action Flow:

Edit Icon → Edit the mentioned Fields → Click Save Icon

In the case of **Deleting** an entry the user must select **Delete**, then user will be able to select a Predefined **Reference No.** and upon which the user will be prompted to a popup message that to enter a Reason to Delete the Entry as **above Image**. After Entering a Reason, User will be able to Click OK and that particular Entry will be Deleted. When User didn't enter any Reason then popup Message will appear and user won't be able to delete the Entry.

**Action Flow**

Delete Icon → Reference No. → Reason → Select OK → Record Deleted

**Cost Process**

Cost Process imports transactions of Other Charges and Commercial Invoice
Upon clicking **New** the system user will be prompted to Select a **BL No.** upon which the System User can edit the Exchange Rate then user may click **Save** or if user needs to view the document then user will be able to view by clicking **Preview**.

**Action Flow:**

New → BL No. → Exchange Rate → Click **Save** Icon/Preview

**Good Received Note**

GRN known as Good Received Note, in the accounts payable process by confirming that the items have been received as expected that is accordance with the original order, and that the items can therefore be invoiced by supplier and subsequently paid for. This will be internal evidence of goods received to process and match against your supplier invoices/purchase orders.
Upon Clicking **New**, the user will have the option of selecting a **BL No** and then select a GRN Type, Location Code, Supplier and Location Code are Mandatory Fields, user must fill the fields and user will be able to insert Remarks.

- When user double click the amount field in the grid, a popup box will appear. When selected product is a serial type, the below Image pop up box will appear,
• Upon insertion all the data in the above popup box user can click the Tick button. So those information will be added. Then user may proceed to **Save** the entry, by saving it gives a **Reference No.**

**Action Flow**

New ➔ Manual No ➔ GRN Type ➔ Location Code ➔ Remarks ➔ In the Grid ➔
Amount ➔ Enter values in Popup Box ➔ Click Save Icon
Shipment Costing Main Panel: Sub Section 3
(Reports)
**GIT Balance**

Upon Clicking the **GIT Balance**, the user will be prompted to choose a **As At Date**, then the user can get a filtered GIT Balance report, user may click Print to View/Print.

**Action Flow**

GIT Balance ➔ As At Date ➔ Click the Print Icon